EAS Build iOS suddenly threw build error

EAS Build ios works well all the time until I made a couple minor JS changes which are totally unrelated to the build.
EAS Build threw below error message.

🍎 iOS build failed:
Internal Server Error.
Please try again later. If the problem persists, please report the issue.
error Command failed with exit code 1.

Build details: Build Details — 27537d69-b800-42bb-9bd7-310e1d25c2e6 — Expo

Hi, sorry for the issue, can you try now?

Hi, @wkozyra Wojciech
Can you help me with this problem or provide some information?
expo build failed in ios, failed with eslint - #2 by lil-kita

I cannot build for ios at least last 6 hours
There is always the same error but with diff packages (net-info/eslint)
npm install works correctly on my pc

Thanks

@lil-kita It looks like the package in the cache was malformed, I’ll look into that more, for now I manually removed that package, it should work now

1 Like

@wkozyra thank you,
ios eas build works well now

I had the same issue.

[stderr]

npm

5[stderr]

ERR! code E500

6[stderr]

npm ERR!

7[stderr]

500 Internal Server Error - GET http://10.254.24.9:4873/@react-native-community%2fnetinfo - unknown error

Any idea what’s happening @wkozyra? I’m unable to build iOS binaries, and custom dev clients.

I ran a build now, and it worked. I’m assuming the issue is from Expo’s side?

Hi @wkozyra
The issue seems to be fixed for me now. EAS Build ios is working again without problem.
Thank you!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.