BUILD ERROR : Error: ibtool exited with non-zero code: 255

Please provide the following:

  1. SDK Version: 42
  2. Platforms(Android/iOS/web/all): IOS
Modifying NSBundle configuration at /private/tmp/turtle/8ac07016-f936-4cd5-85c9-23373cb08819/archive/Release/ExpoKitApp.xcarchive/Products/Applications/


Using standalone config: {
  isShell: true,
  manifestUrl: '',
  releaseChannel: 'default',
  testEnvironment: 'none',
  updatesFallbackToCacheTimeout: 0


Configuring iOS Launch Screen...


Cleaning up iOS...


Error: ibtool exited with non-zero code: 255
    at ChildProcess.completionListener (/usr/local/turtle-js/node_modules/@expo/xdl/node_modules/@expo/spawn-async/build/spawnAsync.js:52:23)
    at Object.onceWrapper (events.js:421:26)
    at ChildProcess.emit (events.js:314:20)
    at ChildProcess.EventEmitter.emit (domain.js:483:12)
    at maybeClose (internal/child_process.js:1022:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)
    at spawnAsync (/usr/local/turtle-js/node_modules/@expo/xdl/node_modules/@expo/spawn-async/build/spawnAsync.js:17:21)
    at spawnAsyncThrowError (/usr/local/turtle-js/node_modules/@expo/xdl/build/detach/ExponentTools.js:201:45)
    at Object.configureLaunchAssetsAsync (/usr/local/turtle-js/node_modules/@expo/xdl/build/detach/IosLaunchScreen.js:330:53)
    at async Object.configureAsync (/usr/local/turtle-js/node_modules/@expo/xdl/build/detach/IosNSBundle.js:714:7)
    at async Object.configureAndCopyArchiveAsync (/usr/local/turtle-js/node_modules/@expo/xdl/build/detach/IosShellApp.js:367:3)
    at async Object.runShellAppBuilder [as default] (/usr/local/turtle-js/build/builders/utils/ios/shellAppBuilder.js:67:12)
    at async Object.buildArchive [as default] (/usr/local/turtle-js/build/builders/ios/archive.js:39:26)
    at async Object.iosBuilder [as ios] (/usr/local/turtle-js/build/builders/ios/index.js:30:13)
    at async build (/usr/local/turtle-js/build/jobManager.js:181:33)
    at async processJob (/usr/local/turtle-js/build/jobManager.js:118:32)
    at async Object.doJob (/usr/local/turtle-js/build/jobManager.js:49:5)
    at async main (/usr/local/turtle-js/build/server.js:66:13)

I am facing the same issue. iOS build has just suddenly failed. Please advise. Thanks.

I am seeing this same issue as well with building.

Same error here. I don’t know what else to do.
I wasted a lot of time until I came here to the forum. The problem happened at the same time I was deleting provisioning profiles and certificates so I thought that was the problem. I even created a new Expo account, but the problem remains.

Same problem! I’m on sdk 44, android builds work fine, seems to be only ios.

me to i spend 4 hours for this error I don’t know how to fix.

1 Like

can people please elaborate on this? what command are you running? are you using turtle-cli locally or running expo build?

with no other info to go on because nobody has provided any, i will point you to possible solutions here: ios - Why am I getting ibtool failed with exit code 255? - Stack Overflow

I just normally run expo build:ios but today this error appear. Thank you.

I have the same problem. I’m building an app through expo build:ios. Everything worked out yesterday. Today I get an error Error: ibtool exited with non-zero code: 255

you can track the status of this incident here: Expo Status - Classic builds with "expo build:ios" are experiencing a high error rate
you may want to consider migrating to EAS Build or using Turtle CLI while we investigate the issue

I use “expo build:ios” command on cli

It worked just now

1 Like

me too.

I am seeing the same issue

Same problem:

SDK Version: 44
Platforms(Android/iOS/web/all): IOS

this should be resolved: Expo Status - Classic builds with "expo build:ios" are experiencing a high error rate

1 Like

expo build:ios working. Thank you

Thank you @notbrent. Thanks all support. i proud with #ExpoTeam.

Best Regards

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.