Your Android App Bundle is signed with the wrong key, but eas cli has the correct credentials profile

Upon uploading my release build to google play for review I recieve the error " Your Android App Bundle is signed with the wrong key…"

The key the play store is indicating the app is signed with is for another app I am actively working on from the same computer.

I looked on the expo console and confirmed that my app does have the correct credential information on it.

When I run eas build the output information indicates the correct credentials are being used: Using Keystore from configuration: Build Credentials _______- (default). I checked that this string matches only with the one found in the correct app and not the wrong one, however I still get the same error from google play.

I tried changing my slug and name in app.json, no success, tried changing it back no success.

I am using the managed workflow, the most recent eas-cli 2.6.0

Why is android signing with the wrong key, but indicating in the eas cli it has the correct key? How do I sign the app correctly?

@wkozyra, I saw you respond to a few related posts, is this something you might have insight into?

Looking at your recent builds, it appears that there are two package names registered for this app under the app’s credentials at, each with their own upload key. I would recommend checking what’s registered there and comparing it with what the Play Store is expecting, and what package name you specify in your app.json.

1 Like

Yes, thank you that was it. Is it possible to change the store listing to a new slug?

Yep, the Play Store (or App Store, for that matter), does not care what your slug is, they just require certain other things remain consistent (namely package name or bundle ID). If you change the slug to a new app, and want to use the existing key, make sure to upload that with the EAS CLI (don’t have EAS auto-create that).

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.