XDE 2.24.2 iOS Simulator Start Error

Just updated to 2.24.2 from I think I was on 2.24.

Now getting an error opening the iOS Simulator from XDE.

Error in the React Native Packager (XDE Console)

Error installing or running app. Error: Process exited with non-zero code: 1

Simulator is throwing a error… but I wonder if the XDE start parameters have changed.

Process:               Simulator [97628]
Path:                  /Applications/Xcode.app/Contents/Developer/Applications/Simulator.app/Contents/MacOS/Simulator
Identifier:            com.apple.iphonesimulator
Version:               10.0 (851.2)
Build Info:            Indigo-851002000000000~95
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Simulator [97628]
User ID:               501

Date/Time:             2018-04-02 18:51:00.532 +1000
OS Version:            Mac OS X 10.13.3 (17D102)
Report Version:        12
Anonymous UUID:        ***

Sleep/Wake UUID:       ***

Time Awake Since Boot: 3000000 seconds
Time Since Wake:       84000 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x4] Symbol missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Symbol not found: _SimDeviceSpawnKeyArguments
  Referenced from: /Applications/Xcode.app/Contents/Developer/Applications/Simulator.app/Contents/MacOS/Simulator
  Expected in: /Library/Developer/PrivateFrameworks/CoreSimulator.framework/Versions/A/CoreSimulator
 in /Applications/Xcode.app/Contents/Developer/Applications/Simulator.app/Contents/MacOS/Simulator

I am still investigating on my end for my own mistakes, but thought I would note it in case others are seeing the same.

I’m seeing the same thing! Updating MacOS fixed it.

Tried that, doesn’t seem to be working. Restarted computer twice. No more updates available. Any more suggestions?

Ok, my environment is working again. Unfortunately I cannot tell you specifically what the issue was, but here are the steps and the versions I now have.


  1. Started xCode - The update to 9.3 had been auto update installed a couple of days prior, but I had not actually started it since that update. I noticed that on starting xCode it seems to have some installation steps to complete. My guess is completing those installs from the xCode update was the cause.
  2. Restarted OSX
  3. Updated to XDE 2.24.3
  4. NOT DONE - Mac OS High Sierra 10.13.4 Update - I had not yet installed the 10.13.4 update. But will do that shortly and confirm it doesn’t break anything

Current Versions - Working

  • Mac OS High Sierra 10.13.3
  • xCode 9.3
  • iOS Simulator 10.0 running iOS 11.3
  • XDE - 2.24.3
  • exp CLI 51.4.0
  • Expo iOS Client

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.