Why are my EAS Updates not working??

I seem to have huge challenges in using EAS Updates and I no longer understand why.

My SDK version is 47, EAS CLI is 3.4.0. This is managed workflow.
I have setup production branch that alos listens to channel production. We have a custom runtimeVersion set, currently to “48-4.1”.
My latest base app from stores is versioned 4.2.1 and listens to branch production, with runtimeVersion “48-4.1” (image attached). Now this happened:

  1. I made a EAS update, with command eas update --branch production --channel production
  2. Update goes through, my app prompts for update, everything works. (Version codes where updated in the release, runtimeVersion untouched)
  3. I make another release, nothing happens anymore
  4. I uninstall and redownload 4.2.1 from app store.
  5. Even the update that was prompted for installation once, is no longer appearing.
    What is going on??

Iamge about 4.2.1, confirming that runtimeVersion is right.

We don’t have a custom runtime version, but what you describe is the exact same thing that happened to me (EAS Updates not appearing due to 'Failed to download manifest from URL' error)

At first the update worked, then I did eas update again, and now the app won’t get any of the updates at all, and has fallen back to the app store version (I guess because of the error I mention in my thread) but I have no idea what’s causing it. This is a major problem.

hi there!

have you tried following these guides?

See what worked for me below, maybe it will help you identify your problem as well: