WebView unable to load URL, got error ERR_CACHE_MISS

I’m currently developing a mobile app using expo framework, and I use WebView to display web page. The problem right now is I cannot run WebView successfully in my android device (please see below the detail of the android device), while in iOS (iPhone 6s) it worked without any problem.

Please find below the following detail:

  1. SDK Version: 38
  2. Platforms(Android/iOS/web/all):Android version 5.0, Galaxy Note 3

How to reproduce the issue:

  1. Install a blank project of expo. I got the instruction from https://docs.expo.io/
  2. Once done, I replace the App.js code with WebView example from WebView - Expo Documentation
  3. I ran the application by executing “npm run start”
  4. Open the application through expo app in my android device (please see above for the detail of my android device)
  5. I got the following error:
Error loading page
Domain: undefined
Error code: -1
Description: net::ERR_CACHE_MISS
1 Like

Hey @fendi,

Can you share a reproducible example that I can test on my end? Saying to copy and paste code leaves some room for human error.

I created a new project, installed the WebView module and was able to implement the example from the docs on my Galaxy 8 without issue.


1 Like

Hi @adamjnav,

Thank you for the reply.

You can find the reproducible code at the following URL GitHub - fendyaritonang/TestExpoWebView

The issue only happen in Galaxy Note 3. I have tried in Galaxy Tab A and iPhone 6s, and I didn’t find any issue.

Android version of galaxy note 3 is Android version 5.0!

Please find below screenshot galaxy note 3

Galaxy Note 3

Thank you,

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.