v34 upgrade build error

expo build problem upgrading to 34


Error: Unsupported SDK Version!
at Object.ensureCanBuildSdkVersion (/app/turtle/build/builders/utils/version.js:18:15)
at process._tickDomainCallback (internal/process/next_tick.js:229:7)
“expo”: {
“name”: “bilsemtabletdenemesinavi”,
“description”: “Bilim Sanat Egitim Merkezi Tablet Sınav Denemesi”,
“slug”: “bilsemtabletdenemesinavi”,
“privacy”: “unlisted”,
“sdkVersion”: “34.0.0”,
“version”: “1.0.4”,
“orientation”: “landscape”,
“primaryColor”: “#cccccc”,
“icon”: “./assets/icons/app-icon.png”,
“splash”: {
“image”: “./assets/icons/app-icon.png”,
“backgroundColor”: “#D33535”,
“resizeMode”: “contain”
“loading”: {
“icon”: “./assets/icons/loading-icon.png”
“packagerOpts”: {
“assetExts”: [“ttf”, “mp4”]
“ios”: {
“supportsTablet”: true ,
“bundleIdentifier”: “com.mikailcetinkaya.bilsemtabletdenemesinavi”
“android”: {
“package”: “com.mikailcetinkaya.bilsemtabletdenemesinavi”,
“permissions”:[ * ],


“name”: “bilsemtabletdenemesinavi”,
“version”: “1.1.3”,
“description”: “Bilim Sanat Egitim Merkezi Tablet Sınav Denemesi”,
“author”: “Mikail Çetinkaya”,
“private”: true,
“main”: “node_modules/expo/AppEntry.js”,
“dependencies”: {
“expo”: “^34.0.1”,
“expo-asset”: “^6.0.0”,
“expo-av”: “^6.0.0”,
“expo-constants”: “^6.0.0”,
“expo-linear-gradient”: “^6.0.0”,
“react”: “16.8.3”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-34.0.0.tar.gz”,
“react-native-grid-component”: “^1.0.7”,
“react-native-popup-dialog”: “^0.9.39”
“devDependencies”: {
“babel-plugin-transform-remove-console”: “6.9.4”,
“babel-preset-expo”: “^5.0.0”

expo diagnotics output 

 Expo CLI 3.0.10 environment info:
      OS: macOS 10.14.5
      Shell: 3.2.57 - /bin/bash
      Node: 12.0.0 - ~/.nvm/v12.0.0/bin/node
      Yarn: yarn install v0.24.6
info No lockfile found.
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...
success Saved lockfile.
Done in 257.46s. - /usr/local/bin/yarn
      npm: 6.9.0 - ~/.nvm/v12.0.0/bin/npm
      Watchman: 4.7.0 - /usr/local/bin/watchman
      Android Studio: 3.1 AI-173.4819257
      Xcode: 10.3/10G8 - /usr/bin/xcodebuild
      expo: ^34.0.1 => 34.0.4 
      react: 16.8.3 => 16.8.3 
      react-native: https://github.com/expo/react-native/archive/sdk-34.0.0.tar.gz => 0.59.8 
      expo-cli: 3.0.10


Please run expo diagnostics and include the output between two lines containing ``` to mark it as preformatted text like this:

expo diagnostics output

i have added. thanks. Any advice ?

just removed no-publish parameter ; it seems like it first controls old sdk version on expo site

Hi. I see you have a pretty old version of yarn installed. I suppose you are using npm instead, but it seems as if expo diagnostics caused the old version of yarn to install packages and create a yarn.lock file. So you might find you have that and also npm’s lock file.

If the above is correct, I suggest you remove the extra (yarn) lock file, remove node_modules, uninstall (or upgrade) yarn, and then run npm install.

I don’t see anything wrong with the files you have posted (bash is pretty old, but I doubt it’s the problem), so if this is still not working for you, I suggest you try creating a new app with expo init and see if you can build that.

If you can build a new app, then you can compare it to your real app (app.json, package.json, etc.) to see what’s different. If the new app also gets the same error then there is probably something in your environment causing the problem.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.