Use of deprecated folder mapping "./"

Every time I try to eas build -p android I get a whole slew of errors in the Run gradlew that go something along the lines of [stderr] (node:628) [DEP0148] DeprecationWarning: Use of deprecated folder mapping "./" in the "exports" field module resolution of the package at /home/expo/workingdir/build/NavTest-main/node_modules/@expo/devcert/node_modules/tslib/package.json., followed by 🤖 Android build failed: Gradle build failed with unknown error. Please see logs for the "Run gradlew" phase.

I’ve tried editing Node-module files, updating everything on my end, making sure there wasn’t anything included in my build that used deprecated software and it’s still giving me this error. I am fairly new to this, please help!

Hi @estacey

Please run npx expo-env-info and paste the output here.

Then run expo doctor to see if it complains about anything.

In general, you should not have to do this. If you do ever have to do this for one of Expo’s packages you should definitely ask about it and/or report it as a bug.

Off hand I’m not sure what those warnings are about, but warnings should not cause the build to fail.

Expo-env-info got me this:

 expo-env-info 1.0.3 environment info:
      OS: Windows 10 10.0.22000
      Node: 18.1.0 - C:\Program Files\nodejs\node.EXE
      Yarn: 1.22.18 - ~\OneDrive\Documents\GitHub\Newr-Chef\NavTest-main\node_modules\.bin\yarn.CMD 
      npm: 8.8.0 - C:\Program Files\nodejs\npm.CMD
      expo: ^45.0.2 => 45.0.2
      react: 17.0.2 => 17.0.2
      react-dom: 17.0.2 => 17.0.2
      react-native: 0.68.2 => 0.68.2
      react-native-web: 0.17.7 => 0.17.7
    Expo Workflow: managed

expo doctor got me this:

WARNING: expo-cli has not yet been tested against Node.js v18.1.0.
If you encounter any issues, please report them to

expo-cli supports following Node.js versions:
* >=12.13.0 <15.0.0 (Maintenance LTS)
* >=16.0.0 <17.0.0 (Active LTS)

🎉 Didn't find any issues with the project!

This is after I tried updating Node, I was running it on a v16 beforehand and I didn’t get any errors on expo doctor.

Please downgrade node again and post your dependencies here.