"upgrade" is not an expo command. See "expo --help" for the full list of commands.

I am trying to upgrade expo sdk version from 37 to 38 and i am unable to do it. expo upgrade gives this error.

make sure you have the latest version of expo-cli

I have tried to install latest version and multiple times i tried npm install -g expo-cli. but i am still unable to get the upgrade command.

1 Like

Can you run expo diagnostics and paste what’s printed out here?

1 Like

Jumping in since I had a similar problem. I just cracked open a project that has been on the shelf since expo v. 35. I cannot upgrade using expo upgrade since I cannot seem to update expo-cli.

Here’s the printout from expo diagnostics command:

There is a new version of expo-cli available (4.3.1).
You are currently using expo-cli 2.1.3
Run npm install -g expo-cli to get the latest version
[10:38:34] Generating diagnostics report…
[10:38:34] You can join our slack here: https://slack.expo.io/.

OS: macOS 10.15.4
Node: 14.16.0
Yarn: Not Found
npm: 6.14.11
Watchman: Not Found
Xcode: Xcode 10.1 Build version 10B61
Android Studio: Not Found

ERROR: package.json not found!