Updated to expo 20, getting warning about app.json

I updated to expo 20.0.1 , RN 047.1, jest-expo 0.20.0 and react-native-scripts 1.2.2.
When i run the packager I get the following warning:

Warning: Problem validating app.json: regeneratorRuntime is not defined.

3 Likes

I am as well! Thanks

can either of you share the project that this happens on?

1 Like

Sending you an invite now!

cloned it, ran yarn, ran yarn start, worked

yarn dev v0.27.5
$ yarn configure:dev && exp start -c --localhost --ios --no-minify --dev
[exp] Using project at /Users/peter/Projects/preposterous/orchard-react-native
[exp] Warning: Problem validating app.json: regeneratorRuntime is not defined.

node 7.10.1
npm 4.2.0

App still works fine, but you get the warning. I thought it was only taking place when running npm 5, but still happens on v4

Not an issue for me, just wanted to report the warning!

I’m getting this warning as well on expo@20.0.0 and react-native-scripts@1.2.1, and my app crashes with the error undefined is not an object (evaluating 'regeneratorRuntime.mark').

I should include that I’m using generator functions and redux-saga in this project.

This issue / comment is relevant, but I’m just not sure what to do to fix this in my CRNA app while waiting for the next expo-vendored react-native version.

@peterpme I’m sorry if this is a dumb question, but which version of exp are you using?

No question is dumb! v44.0.0

This resolved it for me: https://github.com/expo/expo/issues/519. To be clear, if you have a generator function like function* namedGenerator() {}, you can’t use it directly as namedGenerator, you need to set it as some variable/constant first… e.g.:

const namedGeneratorFn = function* namedGenerator() {};

// This will NOT work!
// export default namedGenerator;

// This will work
export default namedGeneratorFn;
2 Likes

Im not using this namedGenerator() { } function. But i still get this warning message. And after that I never get the build built . I always get this error: undefined

image