Unrecognized operator abs

i have made a login service with firebase and google signin.
On deploying it on a webbrowser it works properly but when i scan the same project with my app i get this error

are you used react-native-reanimated or react-native-gesture-handler

Hey @luckyy14,

Googling the error seems to have brought up a promising thread. https://stackoverflow.com/questions/63315761/react-native-getting-this-error-unrecognized-operator-abs

Remember, googling the error you are dealing with is always a great first step to see if others have encountered said error. More often that not, someone has and they also have found a solution.

Cheers,
Adam

Hey @adamjnav
I’ve never heard of that google you’re talking about, but Binging the error brought up a few solutions, none of which worked for me.

Remember, if there’s a bug in your team’s code, the solution isn’t to condescend to your users. More often than not, they’ve tried available solutions. I ran the suggested command as well as npm install -g expo-cli and am still getting this issue.

Cheers,
Hazel

Please post the output of expo diagnostics run from within the root of your project, and also your package.json.

expo diagnostics

  Expo CLI 4.3.0 environment info:
    System:
      OS: macOS 10.15.7
      Shell: 3.2.57 - /bin/bash
    Binaries:
      Node: 12.18.4 - ~/.nvm/versions/node/v12.18.4/bin/node
      Yarn: 1.22.10 - ~/.nvm/versions/node/v12.18.4/bin/yarn
      npm: 6.14.6 - ~/.nvm/versions/node/v12.18.4/bin/npm
    Managers:
      CocoaPods: 1.10.1 - /usr/local/bin/pod
    SDKs:
      iOS SDK:
        Platforms: iOS 14.0, DriverKit 19.0, macOS 10.15, tvOS 14.0, watchOS 7.0
    IDEs:
      Xcode: 12.0.1/12A7300 - /usr/bin/xcodebuild
    npmPackages:
      expo: ~40.0.0 => 40.0.1
      react: ^16.9.0 => 16.14.0
      react-dom: ^16.9.0 => 16.14.0
      react-native: https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz => 0.61.4
      react-native-web: ~0.13.12 => 0.13.18
    npmGlobalPackages:
      expo-cli: 4.3.0
    Expo Workflow: bare

package.json

{
  "main": "index.js",
  "scripts": {
    "android": "react-native run-android",
    "ios": "react-native run-ios",
    "web": "expo start --web",
    "start": "react-native start",
    "test": "jest"
  },
  "dependencies": {
    "@react-navigation/compat": "^5.3.15",
    "@react-navigation/drawer": "^5.12.5",
    "@react-navigation/native": "^5.9.4",
    "@react-navigation/stack": "^5.14.4",
    "expo": "~40.0.0",
    "expo-asset": "^8.2.2",
    "expo-font": "~8.4.0",
    "expo-linear-gradient": "~8.4.0",
    "expo-splash-screen": "~0.8.0",
    "expo-status-bar": "~1.0.3",
    "expo-updates": "~0.4.0",
    "galio-framework": "^0.8.0",
    "react": "^16.9.0",
    "react-dom": "^16.9.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz",
    "react-native-modal-dropdown": "^1.0.0",
    "react-native-unimodules": "~0.12.0",
    "react-native-vector-icons": "^8.1.0",
    "react-native-web": "~0.13.12",
    "react-refresh": "^0.8.3",
    "react-native-gesture-handler": "~1.8.0",
    "react-native-reanimated": "~1.13.0",
    "react-native-screens": "~2.15.2",
    "react-native-safe-area-context": "3.1.9",
    "@react-native-community/masked-view": "0.1.10"
  },
  "devDependencies": {
    "@babel/core": "^7.13.14",
    "babel-jest": "~25.2.6",
    "babel-preset-expo": "^8.3.0",
    "cross-env": "^7.0.3",
    "expo-cli": "^4.3.4",
    "jest": "~25.2.6"
  },
  "jest": {
    "preset": "react-native"
  },
  "private": true
}