Unknown error when uploading FCM key

I am attempting to upload my FCM api key to the Expo servers using the exp command line tool (v. 55.0.4) but for the past hour I’ve kept receiving the “an unknown error occurred” message described in this post:

However, no solution was provided on the thread.

For your reference, this is the output I get on my terminal:

>exp push:android:upload --api-key MY_TOKEN_HERE
13:54:24 [exp] Reading project configuration...
13:54:24 [exp] Logging in...
13:54:24 [exp] Setting API key on Expo's servers...
13:54:25 [exp] An unknown error occurred.

The slug of the app.json file I’m using is a valid slug and the terminal output clearly tells me I am able to log in to set the credentials.

Any help would be much appreciated!

I am getting exactly the same error. And its happening only recently. It worked fine a couple weeks ago.

Hey @flotzyman and @idrlmartian,

I pinged one of the developers who works on our dev tools. I’ll circle back when I find out more information about this error.



1 Like

I’m having the same issue. I double checked everything and since there is not hint on the cause of the error, i’m guessing it’s eigher something missing in the documentation or an issue with the server.

Raf K

Yep, i have the same issue.

I’m stuck over this step for now, it’s the only thing left so i can publish the application I’m working on. Should we open an issue report on github repo?

Raf K.

hi all, we recently deployed a fix. let us know if that solves your problem with fcm errors. thanks!

1 Like

Great, it worked for me now. Thanks for the quick response and fix :slight_smile:

Awesome - works for me too! Thanks a lot, Expo Team! I appreciate the swift effort!

Same problem here. Any updates on this?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.