Unfortunately, Expo has stopped

My app loads and functions on iOS, but on Android the expo app is crashing. On Android I can load the landing, login, signup screens, but when firing login function the expo app quits and gives error “Unfortunately, Expo has stopped”. However the sign-up function is working properly.

What errors do you see in the device log?

It would not send any errors to the log, it would only crash. I’ve solved some of the issue, and it had to do with react native router flux and the tabs with that

Okay great. Glad you’ve been able to narrow it down!

1 Like

Same problem with Expo using Genymotion, on MacOS, using React Navigation …

I’m seeing the same issue with Expo 23.0.4, react-native 0.50.3, react-navigation on the regular android simulator and a physical Android device both running 8.0 (Oreo)

Anyone got any solution ? I am getting the same issue.
I got this in my cli console

Installing APK 'app-dev-debug.apk' on 'SM-G610F - 7.0' for app:devDebug
Installed on 1 device.


Total time: 3 mins 37.821 secs
Starting: Intent { cmp=host.exp.exponent/.LauncherActivity launchParam=MultiScreenLaunchParams { mDisplayId=0 mBaseDisplayId=0 mFlags=0 } }

But when I try to run the app in my device I got the popup “Sample Expo App has stopped … Close app”
Then it got closed.

Hi, first of all I know that this kind of errors are very annoying… And no errors from expo or debugger whatsoever.
I had the same issue, turned out a syntax error in render function was causing the crash. It might be an extra curly brace or similar.


I have the same issue…I am using Expo on the web…app runs on IOS and doesn’t on android.On android it shows the error “Expo has stopped.open the app again”.

Unfortunately i’m having the same issue. It happens on Android(iOS is fine) when navigating through the app, we’re using:
“expo”: “^30.0.0”,
“react-native”: “github:expo/react-native#sdk-30.0.0”,
“react-navigation”: “^1.5.12”,

Is there any way to debug this other than detaching?

1 Like

Hi @scotttharvey, I have the same issue and am also using react-native-router-flux. Do you happen to remember how you fixed it? Thanks.

You should also add expo-cli to your package.json in addition to installing it globally.

I have not had had to install expo-cli locally in addition to installing it globally. If it’s installed globally, that is enough.

e.g. if you install expo-cli globally and then run expo init, then the resulting package.json will not contain a reference to expo-cli, and it will work correctly.

I’m seeing this “Unfortunately, Expo has stopped” error on my phone like every 20 minutes. I don’t even have the application open in the background and it’ll just randomly popup. The only solution I’ve found is to remove the application and leave it uninstalled. :frowning:

So what do I have to do with “Unfortunately, Expo has stopped”?
Really confusing.
Ah, very dissapointed.