Unexpected behaviors in my android standalone app after is signed by Play Store

Please provide the following:

  1. SDK Version: 39.0.2
  2. Platforms(Android/iOS/web/all): Android


This is the first time i’m deploying an app to the play store and i’m finding a lot of things i can’t understand.

I created a react native app using Expo, i tested it in the expo android app and it worked fine, then i built the apk and installed it in my own phone using the adb install and it worked fine.

BUT, when i uploaded the app to the play store (internal testing) to test the app in more devices i hit the wall with all these things.

  • Some users can authenticate using facebook (firebase) some others can’t
  • The user that authenticate successfully the first time and log out his account, when they try to login again the app never closes the splash screen (Shows GraphRequest can’t be used when Facebook SDK isn’t fully initialized).

This is what i’ve done, so far…

  • Used the android studio to watch the log and found this error (GraphRequest can’t be used when Facebook SDK isn’t fully initialized) Which is really weird, because i have set await Facebook.initializeAsync({appId: "<AppId>",appName: "<AppName>",}); in App.js when starting the app and before calling await Facebook.logInWithReadPermissionsAsync();
  • Have set the Play App Signing Certificate (SHA-1) from Play Store and the Google Certificate Fingerprint given from expo (using expo fetch:android:hashes ) in my firebase app settings and in my Google Cloud Platform’s Api Keys, downloaded the google-services.json from firebase into my app root folder, compiled and uploaded to play store again.
  • Converted my Play App Signing Certificate (SHA-1) to base64 string and set it to my facebook app key hashes

After doing all this i can’t make my app work properly once it’s uploaded to the play store, but works like a charm when i compile it using expo and install it to the device via adb

What am i missing? What am i doing wrong?

If you are using app signing by google play(it’s the default for all new app from past few years), different certificates are used to sign apk/aab to upload to play store and different to sing app in store. (play store is resigning it durring upload)

expo fetch:android:hashes returns hash of upload certificate and you need to use hashes from play console (app signing tab).

Hi @wkozyra , thanks for replying! as i mentioned in my post, i already did that, so, that’s why i find this really strange.

Now, what i have to say is that, i tried to install again my app from the play store and it started to work fine, i think that it takes some time until it updates the new release.

Well, i think that the steps i took to make it work could help other facing the same problem.

Thanks anyway! Greetings from Honduras.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.