Unable to use expo cli due to xcrun error

I often inexplicably get the message below and am unable to continue work
This extremely problematic for me can anyone shed any light on what this is ?

Error running xcrun simctl openurl booted exp:// An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=60):

The operation couldn’t be completed. Operation timed out

Operation timed out

Hey @samtsejerome,

Can you run expo diagnostics and share what’s printed out here. Also, what command are you running to fire up your project?


Next time I get the error I’ll run that diagnostics command and send the output
I was running it with expo start

Jerome Mayeux

this can happen when the simulator does not respond to the command to open it. in this case i recommend closing the simulator with cmd+q if it is running and then press i in expo-cli prompt to open it again

I closed the emulator every time I ran expo start at lest 30 times and always got the same problem so I doubt it’s as simple as that sadly

Jerome Mayeux

the simulator may be in a bad state. in the case that this happens i recommend opening it and pressing “Hardware” in the macos menu bar and then selecting “Erase All Content and Settings…”

Thanks! Next time it happens I’ll give that a try - appreciated

Jerome Mayeux

I just tried that erase content and settings suggestion. But still get:


Jerome Mayeux

it sounds like the server isn’t running. there should be a port on there: exp://

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.