Unable to upload keystore or generate a new one after SDK update

I am working on an existing app which has been redeployed under a new user, since it was previously deployed with a personal account. The first test deployment was succesful, a new set of certs and profiles was created for iOS and the existing keystore was uploaded for Android. (Almost) smooth sailing.

After updating the SDK (34 → 37) however, I am unable to upload the keystore as before as well as generate a new keystore. I run expo build:android --clear-credentials and choose either option, in either case getting An unknow error occurred without any further information. When uploading I get the four step wizard, but immediately after that I get the message. When generating I get it right away.

Output from expo diagnostics:

  Expo CLI 3.21.9 environment info:
      OS: macOS 10.15.5
      Shell: 5.7.1 - /bin/zsh
      Node: 10.15.3 - ~/.nvm/versions/node/v10.15.3/bin/node
      Yarn: 1.21.1 - /usr/local/bin/yarn
      npm: 6.14.5 - ~/.nvm/versions/node/v10.15.3/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      Android Studio: 4.0 AI-193.6911.18.40.6514223
      Xcode: 11.5/11E608c - /usr/bin/xcodebuild
      expo: ^37.0.0 => 37.0.12 
      react: ^16.13.1 => 16.13.1 
      react-dom: ^16.13.1 => 16.13.1 
      react-native: https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz => 0.61.4 
      react-native-web: ^0.12.3 => 0.12.3 
      react-navigation: ^4.3.9 => 4.3.9 
      expo-cli: 3.21.9

Downgrading expo-cli to version 3.20.9 solved the problem :slight_smile:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.