Unable to start expo

First of all i would like to apologize for my english.

I’m trying to build an app learning from the docs and after many tries i didn’t manage to do it.

I tried with 3 physical devices (galaxsy S8, galaxy S10 and Galaxy Note 10).
I tried on 3 computers : 2 windows 10 OS and 1 windows 7

I meet always the same problems:

I followed a bunch of stackOverflow posts or in this forum too.

The first problem wich i could resolve is located on the metro-config directory in the file named blacklist.js. I don’t understand why this problem occur from version 33 ? and is still there in 35 version ?

However it is not the main part of my problems.

When I try to open the app by scanning the QR code i face this error:

The module '../../App' could not be found from 'C:\\sample\\node_moudules\\expo\\AppEntry.js'. Indead, none of these files exist:
* 'C:\\sample\\App(.native||.android.expo.js|.native.expo.js|.expo.js|.android.expo.ts|.native.expo.ts|.expo.ts|.android.expo.tsx|.native.expo.tsx|.expo.tsx|.android.expo.json|.native.expo.json|.expo.json|.android.js|.native.js|.js|.android.json|.native.json|.json|.android.ts|.native.ts|.ts|.android.tsx|.native.tsx|.tsx

I’ve tried all the solutions i found on the web for example here :


the solution as they said is to change
sourceExts: ["ts","tsx"] by sourceExts: ["ts","tsx", "**js**"]

This has to be added to the packagerOpts object in the App.json file.

But when I look at my app.json file there is no packagedOpts entry.

So i added it but it still don’t work.

I have tried many install/uninstall of nodejs v12/v13, expo-cli, react-native and the android expo app on my phones

Hi @zarloon. Welcome to the community!

Once you get up and running with Expo you’re going to love the ease with which things work.
However, there’s a bunch of issues in the community right now that make things a little challenging.

For now I’ll give you the versions of the applications of things that work without needing workarounds.

  • First, uninstall your current versions of node and expo-cli.
  • Then, install node 12.9. download It is the last version that doesn’t have the blacklist.js fixtures issue.
  • Then install expo-cli 3.5. yarn global add expo-cli@3.5 in your command line. (I use yarn. If you use npm I think it’s npm install expo-cli@3.5 --global. This is the last version of expo-cli without packaging install errors in Windows.
  • Run expo init to walk through starting a new project. Choose “Yes” when asked to install decencies, otherwise you will need to yarn install from the project directory. Both work.

From here you should be able to open your app from the Expo on your Android device.
The easiest way to make this happen is to…

  • Sign up for an Expo account on the web.
  • Back at your command line…
    • Without a project running, type expo login and log into the account you created.
    • Type expo start to start your project.
  • In the Expo app on the phone…
    • Go to the Profile tab and log in with the same account.
    • Go to the Projects tab and any running Expo apps will show up.
    • Tap your app and you’re good to go!


i want to thank you for your quick answer.

I made all the changes you said and i works like a charm :smiley:

Many thanks you help me a lot !

1 Like

Dude. You rock. Seriously. Thank you. Works perfectly now!

1 Like

This “solution” is half a year old how do you propose to solve it mid 2020, because the versions you propposed are outdated, also I upgraded node and expo and still have same issue…