Unable to set breakpoints anywhere inside function

I’m trying to debug my expo app but can’t set a breakpoint inside function. I tried using chrome devtools and vcode but same problem in both cases. I can only set breakpoint on function definition lines, not inside…

Hey @levani I’d love to help you through this issue.

Just to make sure, you’ve tried what we prescribe in the docs and you’re still having problems?

Open the app on your device, reveal the developer menu then tap on Debug JS Remotely. This should open up a Chrome tab with the URL http://localhost:19001/debugger-ui. From there, you can set breakpoints and interact through the JavaScript console. Shake the device and stop Chrome debugging when you’re done.



Sorry for the late reply.

I’m doing exactly as described in docs. The source is showing in devtools correctly, I just can’t set a breakpoint. When I click on a line number inside a function to set a breakpoint, the breakpoint is jumping at the function definition line…


Hey @levani I’m not 100% sure how to address this issue. It may be useful for you to provide a screen capture so we can observe the problem. I’ve asked for some help from the team to see if anyone else has experienced this before.

Sorry about this :frowning: I know this must be frustrating.

I did some more digging with the help of a teammate:

There might be something in this issue that helps you.

Also looking for options where you can “enable source maps” may also help too.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.