Unable to retrieve the FCM server key

I’m trying to configure the push notifications for my bare workflow app.
I followed the steps one by one, now I can get the exponentPushToken but when I’m trying to send the push notification I’m getting the error “Unable to retrieve the FCM server key for the recipient’s app. Make sure you have provided a server key as directed by the Expo FCM documentation.”.
I’ve tried the solutions given in other topics but nothing fixed the problem.
I’ve pushed the server key using expo push:android:upload --api-key ---- and I can see it in the profile so it was uploaded successfully.
I’m getting stuck in this problem since days ago.

Are you using organizations at all? (is there an owner field in your app.json?)

Does expo push:android:show show the proper FCM key?

1 Like

I’m not using organizations, but in my app.json there is no owner field (can you please clarify how to put it).
and expo push:android:show shows the proper FCM Key.
Thank you for your attention.

I’m not using organizations, but in my app.json there is no owner field (can you please clarify how to put it).

If you’re not using organizations, you don’t need it. Can you share the code you’re using to retrieve the Expo Push Token, and also share your app.json file?

1 Like


yesterday i’ve tried to create new app using: “npx create-react-native-app” and then doing the same as i did in last app.
push notification is now working in the new one
i don’t know if this can help detecting the problem.

aha I see the issue, you’re not providing your experienceId to getExpoPushTokenAsync.

As we state in the docs, that argument is required in the bare workflow for now.

1 Like

I tried both cases with experienceId and without it, they are leading to the same.
and in the new application that I created with “npx create-react-native-app” both cases -with and without experienceId- is working correctly.

can you send me an email (cruzan@expo.io) with one of the Expo Push Tokens?

i’ve send it.

1 Like

thank you for your attention.
i’ve deleted all the projects in my expo account and rebuilt the server key and android API then providing the experienceId to the getExpoPushTokenAsync.
and now everything seems to be ok.
and tried many projects and all of it are ok.
thank you for your attention.
best regards.

1 Like