"Unable to retrieve the FCM server key..." for Android users

Notifications on Android all of a sudden stopped working in my production app a while ago (iOS is still fine). When trying to send a notification to an Android user, I get a response of:
{status: “error”, message: “Unable to retrieve the FCM server key for the recipient’s app. Make sure you have provided a server key as directed by the Expo FCM documentation.”}

I double-checked the docs and I followed everything properly (again, this was working at one point).

Running “expo push:android:show” gives me:
{“status”:“ok”,“fcmApiKey”:“my key here”}

^My key in Firebase console matches the “my key here” value above.^

Using the online Push Notification tool from Expo results in the same response.

I just did a new Android build, put it into beta via Google Play console and notifications aren’t working for that app either.

***Edit: my google-services.json is in place, is up to date, and is referenced in app.json.

I’m lost. Ideas?

Also FYI, I tried a “expo push:android:clear” and then "expo push:android:upload --api-key “my-cloud-messaging-server-key-here” but it’s still not working.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.