Unable to resolve module expo-app-loading

"undefined Unable to resolve module expo-app-loading from C:\Users\adir2\my-first-RN-app\App.js: expo-app-loading could not be found within the project or in these directories:

If you are sure the module exists, try these steps:

  1. Clear watchman watches: watchman watch-del-all
  2. Delete node_modules and run yarn install
  3. Reset Metro’s cache: yarn start --reset-cache
  4. Remove the cache: rm -rf /tmp/metro-*"

that’s the error I’m getting when i try to “import AppLoading from ‘expo-app-loading’;”
the folder is in the module is in the node_modules folder

Hey @sheseck, if you’re certain you’ve installed the module and you’re still getting that error, have you tried clearing the caches by following the steps the cli recommends that you pasted above?


I was trying some of the steps but some I couldn’t understand how to do it, and i tried to look for a guide that will explain the steps and couldn’t find any.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.