Unable to install .ipa from apple configurator 2 and xcode

This is my first app to try to distribute, a beginner here. Please help me

I have created an app with Expo React Native and wanted to distribute it to my friends for testing. I generate the .ipa file with the command below.

expo build:ios

Expo request for my credentials and some other details when I run the command above and I leave everything to the expo to handle the documents.

With the generated .ipa file above, I use Apple Configurator 2 to install my app, simply “add”>“apps”>“Choose from my mac”>select .ipa. The app appears in iPhone but darker colour and show "Unable To install ‘app-name’. Please try again later. " when I click it. Tried to install with Xcode as well but fail too.

Then I found someone able to solve this issue by register his iPhone’s UDID to the account. Done it but doesn’t work.

I have also created Ad Hoc Provisioning Profile and run it with the command above. For some reason, I can’t build my app and generate an .ipa file with it.

What should I do? Feel free to ask for more information. Can somebody help me to publish a standalone app with expo react native? What are the requirements? I want to install it on my phone only, not for public or commercial use.

One extra information, I have also downloaded a random .ipa file from random website for testing. The result is fail to install as well. Same error.

Hey @kzhenkang, have you tried using TestFlight yet?


Hi @adamjnav, thank you for your reply.

Nope. How do I do it?
As far as I know, you need to use iTunes to register users and upload app. But since Catalina, they take out iTunes.

Hey Kzhenkang,
we run:

xcrun altool --validate-app -f <pathToIpa>/<appName>-<someHash>.ipa -t ios -u <username> -p <Application Loader password in credentials>

Then the same command with --upload-app as the flag:

xcrun altool --upload-app -f <pathToIpa>/<appName>-<someHash>.ipa -t ios -u <username> -p <Application Loader password in credentials>

That runs the same commands as xcode connect did before :slight_smile:

Hi @fillip_jono
Thank you for your reply. I was away the last few days and sorry for the late reply.

I have run the line but return with an error, which I do not quite understand even after some research.
Would you mind helping me look at it? I have a screenshot of the result.

Just one question, does this command line publish my app to the App Store directly?

I have not uploaded an app to the App Store yet, but based on your error messages it looks like the following might have some answers:

1 Like

I generated .ipa as well as .app files of the app. I have install Apple Configurator 2 in my mac os.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.