unable to get credentials

When I run build:ios, the build fails with unable to get credentials, as seen here:

I’ve tried multiple times. I have updated the exp cli. I have restarted my machine. No luck.

I’m not sure why it says Certificate has password because I don’t think I set a password when creating the certificate…

Although the exp cli forces me to enter a password when I do the build, P12 password:, so I just typed in something random. Could that be the problem?

Yes, the tools we use for codesigning do not work correctly with p12 files that don’t have passwords. We hope to resolve this in the future, but in the meantime please specify a password for any certs you upload. Thanks!

Thanks that helps.

Documentation should probably be updated here as it links to this page, which tells you to leave the password blank. I lost a lot of time by this misdirection.

Thanks again!

Thanks for the reminder! Hopefully this commit will make it clearer for people in the future.

I’m having the same error, but in my case I’ve set the certificate password.
I’ve posted it here.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.