Unable to expo build:ios

  1. SDK Version: 33.0.0
  2. Platforms(Android/iOS/web/all): iOS

Upon trying to run expo build:ios I’m unable to get my Apple Developer Account authenticated with one particular project. Strangely, I’m able to build the ipa for other expo projects which have an App.json structured the same way. Here’s what’s happening:

  1. I run expo build:ios and am prompted to login to my Apple Developer account.
  2. I enter my Apple ID and password.
  3. ’ Trying to authenticate with Apple Developer Portal… ’ appears and I wait several seconds.
  4. ’ Available session is not valid any more. Continuing with normal login. ’ appears and I wait several more seconds.
  5. I then get the error ’ getaddrinfo: nodename nor servname provided, or not known
    Authentication with Apple Developer Portal failed!
    Reason: Unknown reason, raw: “Could not receive latest API key from App Store Connect, this might be a server issue.” ’

Again, it’s bizarre that I’m able to build ipas for other projects with manifests structured the same way. I can’t deduce what’s going on here. Has anyone had an experience like this?


I’m having the exact same issue when I run expo upload:ios. I’m running expo 34.0.0.

I’m going to attempt to migrate to expo 35 to see if that fixes the issue.

@chris.viabl Are you experiencing the issue with all your expo projects? In my case it’s only one app. Others are building fine and it’s impossible to deduce why.

@dvho I only have one Expo project.

My problem was due to this: https://docs.expo.io/versions/latest/distribution/uploading-apps/#2-start-the-upload
(Check out the note at the top of the section).

I was able to manually upload using the steps here: https://docs.expo.io/versions/latest/distribution/uploading-apps/#manually-uploading-your-app

Hi @chris.viabl

This should no longer be a problem with current versions of expo-cli.

Hi @wodin,

I still get a different error,

Failed to upload the standalone app to the app store.

GetEnv.Nonexistent: EXPO_APPLE_ID does not exist and no fallback value provided.

Is this a thing I need to provide to expo upload:ios?

1 Like

I am getting the same error as @chris.viabl, before and after updating to sdk35.

This process has previously worked fine for me. Anyone else?

are you using the latest version of expo-cli?

@notbrent I am using version 3.9.0, which I believe is the latest.

are you using windows? this may be relevant if so: https://stackoverflow.com/questions/54166879/expo-ios-build-not-working-could-not-receive-latest-api-key-from-app-store-con

Hi @notbrent, no I am using a Mac

that stackoverflow issue seems to suggest this is caused by network issues, maybe you are behind a firewall or something?

Hi @stephp

Could you confirm which error message you are getting? Is it the errors from the first comment in this thread? Or is it GetEnv.Nonexistent: EXPO_APPLE_ID does not exist and no fallback value provided.?

If it is the latter then could you let us know how you are calling the expo command? (You don’t have to post actual Apple IDs and passwords etc., of course. You can post e.g. MY_APPLE_ID, or MY_APPLE_PASSWORD etc.

See here for options you should/can use:


1 Like

I was getting the same error only recently. For the past 4 months it has worked seamlessly. I only have one expo project. Here’s the error:

Failed to upload the standalone app to the app store.
GetEnv.Nonexistent: EXPO_APPLE_ID does not exist and no fallback value provided.

My expo commands:

expo build:ios - works
expo upload:ios - that’s where the error pops up - doesn’t ask me to enter my credentials for appstoreconnect like before

As provided in the link above


looks like the tags --apple-id (which is your user name) and --apple-id-password are now required where there were not before as it allowed you to enter them later in the upload process.

Fix expo upload:ios --apple-id [your user name] – apple-id-password [your password]


Hi @aleksczajka and @chris.viabl

It seems like this might be a regression then. Could one of you perhaps create a bug report here, giving as many details as you can?

I was downgrading through minor versions and 3.6.0 worked properly, thus the regression must have been released in 3.7.X.

1 Like

Hi @damienix

It looks like nobody has created an issue for this yet. Could you do so and add the above info about it working in 3.6.0 and failing in later versions and any other relevant details?

Done https://github.com/expo/expo-cli/issues/1286

Thanks. Can you run expo diagnostics and paste the output into the Environment section?

Same issue as @damienix

here’s my diagnostic

Expo CLI 3.9.1 environment info:
      OS: macOS 10.15.1
      Shell: 5.7.1 - /bin/zsh
      Node: 12.12.0 - /usr/local/bin/node
      Yarn: 1.19.1 - /usr/local/bin/yarn
      npm: 6.11.3 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      Android Studio: 3.2 AI-181.5540.7.32.5014246
      Xcode: 11.2.1/11B500 - /usr/bin/xcodebuild
      expo: ^35.0.0 => 35.0.1
      react: 16.8.3 => 16.8.3
      react-native: https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz => 0.59.8
      react-navigation: ^4.0.10 => 4.0.10
      expo-cli: 3.9.1

build works fine, upload does not

I did no have this issue with 3.8.0 2 days ago