Unable to downgrade Expo-cli

So I run “npm i -g expo-cli@2.21.2” to downgrade my expo cli version, but after that has completed, i try “expo -V” to check my version, and i’m still on 3.0.8.

Is there anyway i can force this downgrade? or actually get it to work?
Is there something i’m doing wrong?

Any help would be greatly appreciated

Hm I just tried this, and was able to downgrade correctly. This probably has to do with your system’s configuration

Could you run expo diagnostics and paste the output? Maybe you have 2 packages of expo-cli installed somehow? You could check in the folder where you keep your global npm packages

Expo CLI 3.0.8 environment info:
OS: macOS 10.14.2
Shell: 3.2.57 - /bin/bash
Node: 10.16.1 - /usr/local/bin/node
npm: 6.9.0 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Xcode: 10.1/10B61 - /usr/bin/xcodebuild
expo: ^32.0.0 => 32.0.6
react: 16.5.0 => 16.5.0
react-native: https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz => 0.57.1
react-navigation: ^3.3.2 => 3.3.2
expo-cli: 2.21.2

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.