Unable to build to iOS and find logs to help debug

Hi there,

I’ve spent 2 days trying to fix my issues. I am trying to release a new app to EAS build on iOS. The error I get in the logs on EAS build site is:

Running "npm install" in /Users/expo/workingdir/build directory




ERR! Cannot read properties of null (reading 'children')



npm ERR! A complete log of this run can be found in:


npm ERR!     /Users/expo/.npm/_logs/2023-08-14T23_18_44_554Z-debug-0.log

npm install exited with non-zero code: 1

First problem is that path doesn’t exist for the logs so can’t see if there’s any further clues… and secondly I’m not sure how to get past it now! On top of that, i’ve maxed out number of releases trying to fix it, but happy to upgrade if there’s a way to debug these types of issues…

Any ideas? Happy to debug if I can get hold of these local logs… I’m on a mac if that helps.

In your post, please share:

  • Whether you are bare or managed workflow: managed
  • Your eas-cli version: 4.1.2
  • What you have tried so far: cannot find logs beyond generic error messages so hard to go further, have tried expo-doctor and all is green, locally building is working fine

Hi @wickey312

See this post:

1 Like

@wodin you have literally changed my life - I love EAS again! Putting “eas-build-pre-install”: “npm config set legacy-peer-deps true”, has fixed it

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.