Unable to build ios - exit process code 1

I’ve been trying multiple times to build this application using exp ios:build with a release channel. I tried updating my FastLane, logging out and back in to Apple Developer Account, but still no success.

I want to mention that I am re-using a dist cert because I was at the max amount allowed.

Here is the build link:


If anyone could shed some light on this it would be helpful - thanks!

Helllo @bsoungg,
I checked that you’re experiencing the same issue as someone else few days ago, could you please read this thread - [SOLVED] iOS standalone build failed - #8 by dsokal?

Thanks for the reply - I did have multiple iOS dist certifications.

I ended up getting a little further. I cleared all credentials, certificates, and everything from both expo and apple. Clean slate - then I generated all new ones with expo. It built fine.

I then tried building another app and re-using the same dist cert. It built as well.

However, I tried building a third app and re-using the existing one that the other two were using - failed with the same error. So now I’m not sure what I should do.

Build failure:

I’m not able to re-use the iOS distribution certificate from another app. But I need to since the limit for these certification is 3, and we have many potential similar apps to push up. Is there something I’m missing when expo asks me if I want to re-use an existing distribution certificate? Appreciate the help!

I checked logs you sent and I also checked more detailed logs we have and it appears that for this app you have wrong provisioning profile generated, it’s associated with different distribution certificate:
INFO [2018-05-29 12:19:26.37]: ▸ error: exportArchive: Provisioning profile "com.***** AppStore" doesn't include signing certificate "iPhone Distribution: **** (*****)".

That’s good to know. Is there a way I can prevent generating the wrong provisioning profile?
The flow I followed when building the new stand alone apps was letting Expo generate all the certs for me, and then I chose the option to re-use an existing distribution certificate (the first one that expo generated for me).

Is there something I should be doing differently on my end?

Hmmm, interesting. Probably we have some bug in provisioning profile generation process when someone decided to re-use an existing distribution certificate. I’ll try to investigate it and let you know what i found.

Thank you! I was able to recreate it almost every time. The maximum I’ve gotten expo to re-use an existing distribution certificate has been two. I’ve been able to recreate the build failure almost every time.
I think it’s definitely something during the generating of the provisioning profiles when deciding to re-use an existing certificate.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.