UEXGL.h file not found

Tried to upgrade ExpoKit as detailed here: https://docs.expo.io/versions/latest/expokit/expokit

To upgrade to ExpoKit 27, I switched the git tag in pod ExpoKit from 2.2.1 to 2.5.4.

Made the other changes as well (changing references in EXSDKVersions.plist to 27.0.0). Now when I try to build in XCode, I get 'UEXGL.h' file not found in EXGLView.h

Okay, so I was trying to upgrade from 24 to 27, and I saw there were some extra instructions in 26 that I’m trying to follow (adding GL to subspec in Podfile), removing kernel-manifest.json and kernel.ios.bundle

Except that’s not working for me either.

Now I get PBXCp error: Supporting/kernel-manifest.json: No such file or directory

(going to try putting kernel-manifest.json back…)

1 Like

I re-added kernel-manifest.json and kernel.ios.bundle and things are working again with v26.

1 Like

Are you currently still stuck with SDK 26?

You need to both delete kernel-manifest.json and kernel.ios.bundle from disk and also remove them from the Xcode project tree, otherwise Xcode will continue looking for files that don’t exist.

Thanks! I removed both files from the IDE in which I do the JS development and didn’t realize it was Xcode itself that was maintaining that reference. SDK 26 works now, sans kernel-manifest.json and kernel.ios.bundle. Now I’ll check and see if I can upgrade to 27, though I found a workaround for the issue that let me to try and upgrade…

I needed to listen to url changes in a webview with a single-page app. I read somewhere that more recent versions of React Native trigger the onNavigationStateChange even when the history pushState api is used, but I more recently found out that that isn’t true. I guess I’ll still try the upgrade just to keep things up to date.

1 Like

I’m not intimately familiar with Xcode, but I found that after deleting the files from disk, you can go to “Build Phases” tab and find “Copy Bundle Resources” where the kernel-manifest.json file may be included. Select the file and click the - button to remove it. Hopefully that fixes it for anyone else who comes across this.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.