Ubuntu expo Tunnel

Has anyone had luck using expo on Ubuntu. I’ve tried on the same network with no firewalls enabled the normal exp://localhost:19001 and exp://192.xx with a usb connected android, but get random java errors about not finding react-native/node_modules on exp://192.168.1 and the ngrok tunnel option straight up fails every time.
Everything works on my Mac but Linux is so much cooler, so would like to get it going.

Tunnel connected.
Project opened! You can now use the “Share” or “Device” buttons to view your project.
Switched to a LAN URL because the tunnel appears to be down. Only devices in the same network can access the app. You can restart the project to try reconnecting.

I’ve tested ngrok (outside of expo) on a regular website and it works fine

Similar to [SOLVED] Genymotion cannot connect to Expo XDE but I tried the solution from here Packager starts then stops silently which just adds file watchers, and this doesn’t help.

Possible duplicate with less information Struggling to get running on Ubuntu 17.04

Here we go with no tunnel. this error on the phone

I ran into an issue where Docker becomes the preferred network driver and you are hitting the Expo “server” on a non reachable IP from your phone.

hey @gregbenner - I moved this into an issue: https://github.com/expo/expo/issues/new

@jptacek - not sure about the Docker issue, if you can post repro steps and an issue to https://github.com/expo/expo/issues that would be helpful

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.