Turtle CLI build fails.

Please provide the following:

  1. SDK Version: 37
  2. Platforms(Android/iOS/web/all): Android and iOS

I’ve been trying to build android and iOS standalone app using turtle cli but even the standard expo init app is giving me the same error for both android and iOS and I can’t figure out whats going wrong.

The command I am running is

turtle build:android --type apk --keystore-path ./keystore.jks --keystore-alias QG1hcmk2bjc3OTUvZXhwby1

Can anybody help me?

I’m assuming that you verified if package expo is added to package.json and that you ran yarn install already?

If that is the case, check the content of node modules to make sure that node_modules/expo directory exists and it’s not empty.
What version of expo do you have? It would be best if you paste package.json and app.json here.

Thanks for your reply.

Yes, expo is in package.json and I just deleted all the node modules again and did yarn install again but still the same outcome. node_modules/expo is not empty and has the bin, build, node_modules, tools, AppEntry.js, bundledNativeModules.json, package.json, README.md and requiresExtraSetup.json in it

I am using SDK 37


  "expo": {
    "name": "expo-build",
    "slug": "expo-build",
    "platforms": [
    "version": "1.0.0",
    "orientation": "portrait",
    "icon": "./assets/icon.png",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": [
    "ios": {
      "bundleIdentifier": "com.yourcompany.yourappname",
      "buildNumber": "1.0.0"
    "android": {
      "package": "com.yourcompany.yourappname",
      "versionCode": 1


  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject"
  "dependencies": {
    "expo": "~37.0.3",
    "react": "~16.9.0",
    "react-dom": "~16.9.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz",
    "react-native-web": "~0.11.7"
  "devDependencies": {
    "babel-preset-expo": "~8.1.0",
    "@babel/core": "^7.8.6"
  "private": true

Also, if you run turtle setup:ios or turtle setup:android it doesn’t give me any errors

add sdkVersion: "37.0.0" to app.json, it shouldn’t be necessary anymore, but it might fix that issue for you

Thanks a lot. I got it working now

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.