Tunnelling issue using XDE

I was able to use XDE only once to create a project. But now, when I tired to open the existing project or create a new one, I get this error:

Error starting tunnel: Error: Starting tun;nels timed out; followed by Project now opened and can be displayed in simulator or device.

But, I am not able to run any of the menu items under XDE or Project menubar (e.g. install simulator or open in editor, etc).
The extra scripts that run after displaying the “Project is now opened” no longer run. I left this on for a day, thinking my connection was poor and will eventually run, but nada!

What am I doing wrong or have left out? Please help. I have reinstalled expo but getting same result. I also logged out of all other machines where expo is intalled but no help. Thx

Hey @obisi7 this must be really frustrating, I’m sorry you had to go through this, here are some suggestions for things you can try:

Potential Solution #1:

The tunnel software we use is ngrok (https://ngrok.com) so I'd try testing ngrok out to make sure it works on your computer before spending more time. (XDE and exp have a LAN option where your project URLs contain LAN IP addresses instead of the exp.direct tunnel URLs.)

If ngrok works I'd recommend a few things while debugging:

Close your project in XDE and open it again.
Try to load the URL in your browser on your computer (switch out exp:// for http://). If that works, the development server is up and running.
Try to load the URL from your phone's browser to make sure your phone can reach your development server.
Lastly, open the URL in the Expo client.

If your scenario involves using Windows + VirtualBox, this is a solution that worked for someone else:

Solution for windows 10.
Go to cmd and write ipconfig.
Look what is the first Ethernet adapter.
It should be Ethernet adapter Ethernet.
If it is not and it is something like Ethernet adapter Virtualbox...
Then this is the problem voalaa. Expo is taking the ip adress of the virtualbox.
So go to "Network connections" right click on the adapter you want disable and change the status to disable.
Connect you computer to ethernet and you phone to the same wifi network.
Restart Expo, then the default url should be changed.
Select host->lan, start the app and then -> run on android.
That's it.

If those options don’t work for you, I’d love to learn more about your machine, which version of node are you running, and what other developer tools do you have installed to do your job.

Thanks for using Expo, look forward to helping you out in the future.

1 Like

I qm running on Mac OS X .

I entered http://localhost:19000 into my browser and got the following returned:

{“name”:“mytestapp”,“description”:“An empty new project”,“slug”:“mytestapp”,“privacy”:“public”,“sdkVersion”:“21.0.0”,“version”:“1.0.0”,“orientation”:“portrait”,“primaryColor”:"#cccccc",“icon”:"./assets/icons/app-icon.png",“loading”:{“icon”:"./assets/icons/loading-icon.png",“iconUrl”:“http://localhost:19001/assets/./assets/icons/loading-icon.png"},“packagerOpts”:{“hostType”:“tunnel”,“lanType”:“ip”,“dev”:true,“strict”:false,“minify”:false,“urlType”:“exp”,“urlRandomness”:“z6-j3u”},“ios”:{“supportsTablet”:true},“xde”:true,“developer”:{“tool”:“xde”},“env”:{},“bundleUrl”:“http://localhost:19001/node_modules/expo/AppEntry.bundle?platform=ios&dev=true&strict=false&minify=false&hot=false&assetPlugin=expo/tools/hashAssetFiles”,“debuggerHost”:“localhost:19001”,“mainModuleName”:“node_modules/expo/AppEntry”,“logUrl”:“http://localhost:19000/logs”,“iconUrl”:"http://localhost:19001/assets/./assets/icons/app-icon.png”}

I have tried closing and opening my project but no luck.
Not sure what you mean by “Lastly, open the URL in the expo client”…

Having gotten a brief taste of expo and XDe, I am excited but now can’t use it. Thanks for following up on this.

You can’t open Expo projects in the browser, you have to open them on your phone with the Expo Client installed.

understood. I wasn’t trying to open the project on my browser. When I tried to open the project in the simulator by choosing device, I get error an error that it can’t be done. When I chose to install the iOS simulator from the XDE menu, nothing happens even though the last time this works, my iOS simulator launched which allowed me to open the project in the simulator via choosing device.

Now I have tried selecting different protocols and hosts in the XDE settings but no luck. Even when tunnel was not selected, it reports that tunneling error. I am stuck. I have followed all the online examples (from Expo) and project creation looks simple and straight forward.

You create a project, packager runs wihrtout the red text tunneling error, and you open the project on the device, and voila simulator opens what project. Then to make changes, you select “Open in editor” or use any editor to open the project and everything works. I got to experience this flawless activity only once and nothing works for me now. I am stuck at the tunneling error red rtext.


So I had a previous question you haven’t answered, which version of node are you running on your machine, what other developer tools do you have installed to do your job?

Another option for you, is to try our command line tool here and not use XDE, I’m curious if that could work for you too. https://docs.expo.io/versions/latest/guides/exp-cli.html

sorry i missed that question. I am running version 4.6.1 which i downgraded to from 5.0.3 when I saw a warning upon starting expo

no other dev tools installed as yet for expo. Just getting my feet wet with excitement and now can’t even proceed. thx for your help

When i tried opening project in iOS simulator from the devices tab, i get:

Command failed: osascript -e tell app “System Events” to count processes whose name is "Simulator"
error. Plus nothing happens when i choose "install iOS siulator from the XDE menu items. I have also tried opening the project from qr code on my iPhone but got error connecting with server.

uummm. i am being forced to go back to using web storm i guess though i love the promises of expo

1 Like

I rebooted my machine and now able to launch the iOS simulator without any error. But the process is stuck on "installing expo on iOS simulator for the last one hour and still counting. Something must gone awry. I am afraid to shut it down and revert back to old problem.

Any ideas?

Hurray, success! I restarted everything including opening simulator. I think the expo installation on the iOS simulator got stuck. Now all is good.

Strategy would be to reboot and restart all processes. thx

1 Like

Glad it worked @obsi7