Tunnel URL not found, failed back to LAN URL

I keep getting this when I attempt to switch over to a tunnel connection and I really have no idea why?

Hey @alanc14,

This occurs when the ngrok tunnel gets disconnected. It can often be remedied by simply restarting the instance or trying to switch back to tunnel after it goes to LAN. Running expo start --tunnel will tell the CLI to start via tunnel. Usually it’s a transient issue, but if you consistently can not connect via tunnel it may be a network issue.



@adamjnav, I’ve restarted the instance many times and it doesn’t matter if I pass --tunel arg or not.

Do you have any suggestions on what network issue it could be?

I’ve set EXPO_DEBUG to true and the issueId I’m getting is "tunnel-url-not-found".

I have this issue constantly. The most common reasons in my experience are as follows:

  1. Inconsistent internet connection. If it drops for a moment, even momentarily, it seems to throw everything.
  2. All devices not on same network.
  3. Need to close and restart packager from scratch (unsure why this helps).

Some combination of all this and repeated trying and resetting always fixes it for me. Not ideal, but if you have to use tunnel…

Yeap, it’s a stranger thing, because the first project I created days ago using expo-cli it worked out of the box. All of my devices are in the same network, I always restart the packager since this issue’s started and the connection seems ok. It’s happing for days now.

If I figure something out, I’ll share here.

It did help running the following commands:

expo start

Then in other cmd/powershell instance but in the same directory

expo publish

logging into expo from cli solved this issue for me on mac and ubuntu

expo login
expo start --tunnel

Thanks, was looking for a solution to run my app for the first time for already 5 hours, Im so glad I found this


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.