Trouble linking with Expokit, unable to find Libraries in XCode

Quick background

I have recently to ejected to Expokit. After I eject, the project runs perfectly from Xcode.

The problem (I think) is that I haven’t been able to successfully link to any libraries. (so far I have tried react-native-iap and react-native-linear-gradient ).

After giving up on using “react-native link”, I have been trying to follow the manual installation instructions. If you think my specific question is not getting at the underlying issue, I would appreciate questions or ideas here!

Specific question

In the manual instructions, these libraries say to " In XCode, in the project navigator, right-click LibrariesAdd Files to [your project's name]"

However, I can’t seem to find Libraries in my project navigator and have instead just tried adding to my project.

Is there something I am missing here? My eject not working properly? I am using Xcode 10, did something change with how Xcode works?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.