Toggle Development Mode On/Off doesn't work

Hi guys, Hope your monday goes well.

I’ve been sitting here for the last few hours trying to figure out why toggling development mode on/off literally does nothing.

If development mode is toggled off, it still allows me to pull up the developer menu. Of course if I switch developer mode off I refresh everytime. I’ve removed XDE and installed it again, but still to no avail. Has anyone else had this problem? And if so how did you fix it?

Thank you for your time.

1 Like


I am not clear in your question. Can you further elaborate please?

Hi Edgar. Thanks for replying.

My confusion was that if I had development mode toggled off it would still allow me to pull up the developer menu, In previous versions of Expo when development mode was off the Dev menu wouldn’t show up at all. I was confused and wanted to see if this was a bug or if this behavior was intended.

hey, is this on iphone or android? i believe on iphone developer menu shows up regardless, haven’t checked on android. could be the same.

if you want, you can also make a feature request on and if it gets enough votes the expo team makes it happen :smile:

It was on iphone. And you are correct this behavior was intended. I was so used to using android emulators that I thought the menu wasn’t supposed to show up on iOS.

I had a similar problem, and when I tried to fix it (I changed the versions of the node, restarted, re-created the new project, switched mode using the CLI and using Expo Dev Tools) I got the opposite situation: in spite of the mode switching messages, only logs were displayed
__DEV__ === false, development-level warning are OFF, performance optimizations are ON
, and in the application you cannot open the developer menu. How fix it? Please help me.

Linux Mint 18.2, Node v8.11.3, v8.12.0, v10.11.0, v10.4.1, Expo v 30.0.0

Having similar problem, but it started happening after I published my app. Now even if I turn on development mode I don’t get errors logged when the app crashes.

Same here, having this problem… do u guys able to solve it? I ma half way in my project and it happen even i init a new project…

Hi everyone,

Have a similar issue on my iPhone and Android phones. The developer’s menu doesn’t shows up in my app. Tested this on emulators and real devices. Shaking, Cmd+M worked before but suddenly stopped right now.

The build logs show the following:

__DEV__ === false, development-level warning are OFF, performance optimizations are ON

Running the debug configuration of my build in the IDE, but it still reports DEV to be false. Can’t find the way to switch the DEV to true.

UPD: Tried the following tip: Go to terminal and press “P” to toggle production/development mode. You will see something like this:

[11:34:35] Metro Bundler is now running in development mode.
Please reload the project in the Expo app for the change to take effect.

Press ? to show a list of all available commands.

Found it here:

Also tried the steps described here:

THIS DOESN’T WORKS and still reports DEV === false

UPD #2: It turns out the React native caches the metadata locally on the device, so you need to remove the app on iPhone and clean the app data on Android to see the changes.
Fund it here:

Now everything WORKS AS EXPECTED!