Timeout when building

The build keeps timing out… I have been experiencing this issue for over a week now.

Never had any issues building before this.

Platform: ANDROID
Command: expo build:android

‼ Timed out.
Timeout reached! Project is taking longer than expected to finish building, aborting wait...

Around 12 o’clock yesterday, I saw about 80 queues waiting unhandled. Maybe there was a problem with the server.

Same thing happened to me today. Also around 12:00 AM
I run the command from the build in terminal is vs-code.
I can see the timeout appears in this terminal but when you go to the recent builds of the project, the build is still in queue.

Same thing has happened to me yesterday, as well as this morning. I ran the command in the terminal of PyCharm. My terminal tells me that the project timed out, but the webpage with the build log for my app gives no indication that it timed out.


The expo command waits around for the build to complete, but if it takes longer than a certain amount of time (e.g. because too many people are trying to build at the same time and the servers are busy), then the expo build:android command will time out. This does not mean that the build itself has timed out. Only that the expo command running on your machine has given up waiting.

To see if the build is still going, log on to https://expo.io and check the builds there. (When you’re logged in they should show up here.)

Was a busy day that day it seems. Build was fine during downtime.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.