Timeout of 60000ms exceeded

I’m trying to create a new project on XDE but it keeps failing during download.

Tried both Blank and Tab Navigation.

Also tried initiating a new project manually by ‘react-native init’ then importing it to XDE, but I keep getting weird errors when everything is complied.

The one I’m currently getting now is 'Unable to resolve module /react-native/Libraries/Renderer/Shims/ReactNativeBridgeEventPlugin… ’

tried ‘rm -rf ./node_modules && npm install’ but still getting the same error

can anyone help please?

Hi, sorry it keeps failing during download. You can try manually downloading the template project here: http://expo.io/--/api/v2/versions/download-template/blank

The result should be the same as a new XDE project.

1 Like

I must say I’m a bit disappointed of RN. Since 2 days I try to see anything work but there is one issue after the other. Today I spent all my time to connect my Android to the developer server. But the device is not able to realize being in the same wireless network.,The solution (for some, not for all) is a long manuell network setting change in their system. As if that couldn’t be managed in the Expo app and/or the development server software. Finally I tried to install the Tab Navigator template. DSL 400,000 but always a timeout after 60 seconds. Yeah, that’s why I found this thread. And the solution really is a manual download? It seems to me that there is no good management for this project.


sorry to hear you’ve been having so much trouble @marcophono2 :frowning: fwiw you could try out https://snack.expo.io/ to make the development process easier for you if its taking you a really long time to debug the things on the xde

1 Like