"There was an unexpected error delivering the notification" (iOS Push Notifications)

I’m getting an error when trying to send push notifications to any of our iOS devices. This is a standalone app on the App Store.

I’ve tried:

  • exp build:ios -c
  • Delete iOS Distribution certificate, Apple Push Services certificate, and provisioning profile from Apple Developer account
  • Publish a new app version to iTunes Connect

I’ve also tried:

  • exp build:ios -c
  • Let Expo handle all certificate provisioning
  • Publish a new app version to iTunes Connect

Despite these efforts, I continue to receive the same error message.

Does anyone have any ideas?

Hey @andrewlee86,

You might want to take a look at Chuyee’s post at the bottom in this Github issue: https://github.com/expo/expo/issues/382

It looks like they got this error resolved after doing a complete (I think manual) wipe of their APS certs and prov profiles.



Hey @adamjnav,

I’ve already tried wiping all of my certificates and provisioning profiles from my Apple Developer account to no avail. Also, I don’t have an ad hoc profile.

I started out with letting Expo handle all the certificate provisioning, then did a exp build:ios -c so that I could use my own CSR to generate my own certificates and provisioning profiles but that didn’t work either. Since the error didn’t go away after using my own self-generated certificates, I decided to let Expo handle the certificate provisioning once more. This is my current state of affairs.

Got it. Yeah, I didn’t mean to recommend what you’ve already tried yourself. One thing I noticed in that github user’s post was that he deleted both development and production variants.

I’ve deleted all certificates and provisioning profiles and let Expo handle the provisioning process but I continue to get the same error message.

Has the Expo team received any similar issues?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.