The recipient isn't associated with any device [PUSH NOTIFICATION]

Hi guys, i’m stuck with this, all of my devices have push expo token sended to my server, but some token didn’t work, means that devive doesn’t get any notification (standalone App) but some does.

Then i try to send with PostMan with not working token, i got this :

  "data": {
    "status": "error",
    "message": "The recipient \"ExponentPushToken[zwrMAkOXAmqoNCllp6G-RU]\" isn't associated with any device",
    "details": {
      "error": "DeviceNotRegistered"

So can anyone can help me ??

Is there any chance you disabled push notifications on those devices? The token may have been invalidated by Apple. cc @ide

Additionally, are you sure these are users who have granted permission to receive notifications?

FWIW, I had trouble with PostMan specifically, try with a different REST client.

I have the same problem, everything worked under Expo, but when I ejected, and built a standalone version, I got this error. But the standalone is run using Fastlane Beta, could this be the cause?

Ejected apps don’t work with Expo push notifications.

I’m wondering how expo in this diagram

knows where to send notification to, I think it’s registered in let token = await Notifications.getExpoPushTokenAsync(); ?

I have the same problem trying with a real iphone 6 with expo client

Furthermore you said permissions need to be granted for notifications but in expo settings on my ios device there is no setting for notification?

Hi same problem here… pls someone tell me how to resolve. ?

Make sure you’re using the Expo Permissions API and that the user has given permission to receive notifications. This is what tells the OS to provide a device token that the Expo push notification service can use to send notifications to the device.

Having the same issue for standalone iOS app built with exp:build. Using Permissions API and devices allowing notifications but receiving the same error as @haieric96

Hi @paddylb - We’ve deployed an update to the iOS standalone app builders that fixes this issue.

This incident affected only IPAs built with exp build:ios between 2018-01-22 4:30pm to 2018-01-27 10:05pm (Pacific time). This incident did not affect any previously built IPAs, including IPAs that developers may have published to the App Store.

New standalone apps whose builds started after 2018-01-27 at 10:05pm Pacific time will include the new code that correctly registers for push notifications. Developers who have created builds affected by this incident will need to create new IPAs.

You can get a new standalone app IPA by running exp build:ios. Make sure to bump your IPA’s version number so that you can submit the new build to TestFlight (iosbuildNumber in app.json might help:

1 Like

I have ejected using expokit and i am not using push notifications(and have no plans of using them). However whenever i submit my app to app store for review i get below warning

We have discovered one or more issues with your recent delivery. Your delivery was successful, but you may wish to correct the following issues in your next delivery:

Missing Push Notification Entitlement - Your app appears to register with the Apple Push Notification service, but the app signature’s entitlements do not include the “aps-environment” entitlement. If your app uses the Apple Push Notification service, make sure your App ID is enabled for Push Notification in the Provisioning Portal, and resubmit after signing your app with a Distribution provisioning profile that includes the “aps-environment” entitlement

Though this is just a warning and app still got approved, i want to confirm that is there is way to get rid of this warning? I am using expo 23 sdk. Thanks.

1 Like

@hamezgul - This message likely occurs because Apple’s static code analyzer found references to push notification registration APIs but your app does not have push notifications enabled. You can either (a) enable the push notification entitlement the same way you’d do it for any other iOS app, (b) delete the push notification code from your ExpoKit dependency (not recommended, though), or © ignore the warning.

1 Like