The last mile of CI with expo

I know there are other topic about this problem Upload iOs: [iTMSTransporter] -Djava.ext.dirs=....../ext is not supported. Use -classpath instead.

[iTMSTransporter] -Djava.ext.dirs=/Applications/ is not supported. Use -classpath instead.

[23:57:17]: [iTMSTransporter] Error: Could not create the Java Virtual Machine.

[23:57:17]: [iTMSTransporter] Error: A fatal exception has occurred. Program will exit.

but there are no useful response.

I have struggle days to resolve this problem.

but it still not work.

I am very confused, why not fixed the problem in the last mile?

expo’s big feature is easy to setup, so it should be easy to work with CI.

also please see this [deliver] During Deliver process I get a Transporter error: Could not create the Java Virtual Machine · Issue #15323 · fastlane/fastlane · GitHub.

We can not go back to use xcode 10. we are using xcode 12. also I have tried xcode 10 on bitrise, it did not work, as the node version is too old.

Please solve this problem.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.