The Expo SDK requires Expo to run. It appears the native Expo modules are unavailable and this code is not running on Expo.

I am facing this error when I run my project using command expo start. Below is the reference image
My project config is

“dependencies”: {
“expo”: “^31.0.0”,
“react”: “16.5.0”,
“react-native”: “

So I tried to create a new project with expo command
expo init
cd Projectname
expo start

here is the latest project config but I am unable to run the project which initially created by expo command too.

Please help me out as I have spent my whole day on this issue but not able to fix it yet. :frowning:

“dependencies”: {
“expo”: “^32.0.0”,
“react”: “16.5.0”,
“react-native”: “

I have also do following troubleshoot but not got succeeded yet

  • Uninstall expo CLI and install it again
  • Delete node_modules folder and install it again
  • Check version of node, npm, react-native also downgrade them but not succeeded yet

Update your expo application in mobile

1 Like

I have the same issue,

I did all of it, fresh SDK32 project eject with Expokit.

  • Installing Expo from playstore
  • Update expo-client from 2.2.0 to 2.2.x
  • ran exp install:android
  • installed expo APK manually
  • killed uninstalled expo app

When I launch my app on Android studio on my connected Galaxy J3 I still get the same error. Same thing on the emulator.

Feeling lost at this point.

I tried too

I had the same issue after upgrading to SDK32.
Have fixed by removing :
and installing everything again
(on Windows)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.