Submit to Testflight: App can't be opened anymore


I’d successfully submitted an EXPO/EAS managed app to iTunes Connect / Testflight, everything worked fine.
I submitted another build, invited two new testers but when they try to start the build, they get: “your request couldn’t be completed.”
No error code or something. The build works fine in internal testing on different devices.
Submitting another build doesn’t change anything, while testflight shows the right version of the newest build.

Researching the web some mention that not increasing the build number manually in app.json could be the issue, but i did that multiple times. Also prebuild --clean didn’t change anything.
Sometimes the used certificates could be an issue, but i used the production profile.

How can i solve this? Thanks in advance for every help.

I don’t know if it helps you, but I think it’s the issue of the version that doesn’t update correctly, try putting in the eas.json :

"cli": {
     "appVersionSource": "remote"

later in the part of the build.production:

"production": {
       "autoIncrement": true,

this will let expo handle the internal checking itself.
Now all you have to do is increase the versions in the package.json (version) and in the app.json (version)

I don’t know if this helps you, since I don’t have more information about its configuration, I couldn’t tell you if that is the problem, but in my project that solved the problem.