Stuck with Podfile.lock on EAS build due to Firebase

Please provide the following:

  1. SDK Version:45
  2. Platforms(Android/iOS/web/all): iOS
  3. Add the appropriate “Tag” based on what Expo library you have a question on.

Hello everyone!
I have the exact same problem mentioned here:

Unfortunately I arrived 2 days too late and that post closed automatically.

So! Installed Firebase for Notifications, Analytics and Crashalytics and it works perfect in Android, but in iOS build in expo.dev it fails horribly:

[!] CocoaPods could not find compatible versions for pod "Firebase/CoreOnly":
  In Podfile:
    EXFirebaseCore (from `../node_modules/expo-firebase-core/ios`) was resolved to 5.0.0, which depends on
      Firebase/Core (= 8.14.0) was resolved to 8.14.0, which depends on
        Firebase/CoreOnly (= 8.14.0)
    RNFBApp (from `../node_modules/@react-native-firebase/app`) was resolved to 15.2.0, which depends on
      Firebase/CoreOnly (= 9.3.0)
Error: Compatible versions of some pods could not be resolved.
You are seeing this error because either:
  - Versions in the Podfile.lock cached by EAS do not match required values for some of the libraries, it can be triggered when upgrading Expo SDK or any other library with native code. To fix that add the "cache.key" field (it can be set to any value) in the build profile in eas.json to invalidate the cache.
  - Some of your npm packages have native code that depend on different versions of the same pod. Please see logs for more info.

I think Stuck with Podfile.lock on EAS build - #15 by wkozyra is really close to the solution, but I am not sure.

expo doctor:

Expected package @expo/config-plugins@^4.1.0
Found invalid:
  @expo/config-plugins@5.0.1
  @expo/config-plugins@5.0.1
  @expo/config-plugins@5.0.1
  (for more info, run: npm why @expo/config-plugins)

SOS please!

Hey all ! Up

Just updated from expo build to eas and end up stuck as @sirnejo while trying to do a production build.
i only have "expo-firebase-analytics’

CocoaPods could not find compatible versions for pod “Firebase/Core”

i try adding ‘expo-firebase-core’ thinking it was the problem, but it just added an other similar pod file error.

Is there a way to patch this ? or are we missing some configurations ?
I tried a lot of things and still end up failing :smiling_face_with_tear:

Thanks for your help

p.s: Yes i removed the cache :face_with_peeking_eye:

You are using incorrec version of expo-firebase-analytics for your sdk, check output of expo doctor.

Hey @batmat

I had some weird issue like you

Can you double-check your iOS deploy target

        ios: {
          deploymentTarget: "13.0",
        },

You can have a look at this issue, I had the same error with another library

@wkozyra Doctor was fine. Thanks for your help :wink:

@flexbox Hey thanks a lot it seems my build succeed, i still need to try it out :wink:

Doctor was fine.

No, it was not

From your build logs

[stderr] [01:33:03] Some dependencies are incompatible with the installed expo package version:
[stderr] [01:33:03]  - expo-firebase-analytics - expected version: ~7.2.0 - actual version installed: 7.1.1
[stderr] [01:33:03]  - react-native - expected version: 0.69.6 - actual version installed: 0.69.5

Your last build succeeded because you removed expo-firebase-core from package.json. It was failing before because you used correct version of expo-firebase-core, but the wrong version of expo-firebase-analytics
Right now both packages are on the wrong version(for that sdk), but now they are compatible with each other.

You took one build log, you didn’t check all of them no ? thank you for your precious time