Stuck on upload updated app to App Store Connect

  1. SDK Version: 38.0.1
  2. Platforms: iOS

I have built an app on Expo successfully, I can even import the app in the simulator and test it.
But when I run the command `expo upload:ios --apple-id --apple-id-password --app-name , it gets stuck on

Going to upload updated app to App Store Connect
This might take a few minutes. Please don't interrupt the script.

It’s stuck here for a couple of hours now, my internet connection is pretty good so I don’t think that’s the problem. I even tried doing the manual process in which I uploade the .ipa file to Transporter, but there also when I click on Discover, I am stuck on “VERIFYING APP - Authenticating with the App Store…”

This is the first time I am pushing the app to the App Store. It would be great if someone could help me out a litte.

this sounds like there could be an issue right now with apple servers, it happens occasionally. try again in a few hours

It has been happening since 12+ hours. I have tried around 4-5 time, but everytime it’s getting stuck.

So for anyone stuck on this, I updated macOS, expo-cli and re-installed Xcode and now it works.

1 Like

You can also use Apple’s Transporter app -
This will allow you to upload .ipa file to App Store Connect.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.