Struggling with exp build:ios

Hello, I’ve been trying to build my app for some time today, and sadly all tries failed.

Here’s a picture of the phenomena :
along with the respective requests IDs :


Sometimes it get past credentials, often not. This is very confusing as it seems random.
Thank you for looking into this issue !

Well, after trying again for a while, it just worked.

I have a wild guess that the service can be too loaded at times (too many users trying to build at the same time), making the build fail.
Even so, it is a little bit frustrating not to know what’s happening.

EDIT : and then after using build:status : “There was an error with this build”

ID : 8e1f10b0-362c-4416-8b14-589cc4734ca0
EDIT2 : another one, 2 hours later : 18c57d00-1b2e-401d-9ce5-6038b580fed0

Please try once again.

Sorry for the trouble.

1 Like

Tried again :

“There was an error with this build”

Good thing is at the time of testing, it don’t stop as before on auth things.

@coldk are you an admin on your Apple developer account?

Nvm, @coldk, looks like the errors were transient. Just re-ran your build and it succeeded. Go ahead and grab the link to your IPA with exp build:status

1 Like

Build ID: 81434452-e11f-43cf-a713-72e413053d9b
Build ID: 1e88d9a7-5e2e-4755-8481-890c2be541a2
Build ID: 1c1dbe75-0351-4897-96bc-468c19ee0724
Build ID: 553adca9-6522-4d5b-947e-6faf3c500ccc
Build ID: e30965e9-708a-41c7-92e3-cd8a427ae8d9

Every time expo show me error: iOS: There was an error with this build.

That’s true ! Thanks for your assistance :slight_smile:

Looks like you uploaded your own p12, but it isn’t validating correctly: pkcs12: expected exactly two safe bags in the PFX PDU.