Still ios build error


I posted this question already previously but no answer yet. This is preventing me from creating a build for ios.
In the step Configuring NSBundle I get this error:

Modifying NSBundle configuration at /private/tmp/turtle/5b9d5ca5-b525-472c-9bd4-e706ae21f33f/archive/Release/ExpoKitApp.xcarchive/Products/Applications/…
Using standalone config: { isShell: true,
manifestUrl: ‘Expo’,
releaseChannel: ‘test’,
testEnvironment: ‘none’ }
Configuring iOS Launch Screen…
Bundling assets…
Cleaning up iOS…
Error: Asset bundling failed: Error: is too small
at Object.configureAsync (/usr/local/turtle-js/node_modules/@expo/xdl/build/detach/IosNSBundle.js:672:15)

Anyone any idea?

Expo CLI 3.13.1 environment info:
OS: macOS 10.15.4
Shell: 3.2.57 - /bin/bash
Node: 12.13.1 - /usr/local/bin/node
npm: 6.12.1 - /usr/local/bin/npm
Android Studio: 3.5 AI-191.8026.42.35.6010548
Xcode: 11.4/11E146 - /usr/bin/xcodebuild
expo: ~36.0.0 => 36.0.2
react: ~16.9.0 => 16.9.0
react-native: => 0.61.4
expo-cli: 3.13.1

It’s failing on check that is intended to detect invalid assets (few bytes). Just remove this file or set assetBundlePatterns in way that is not pointing at this file

Hi, thanks for the reply.
My assetBundlePatterns array in app.json was set to ** / *
This means it looks for all assets under the root directory.
I changed it to assets/* and now it works.

It looks like the default settings for this is ** / * when I run expo init.
Could it be that it found an empty asset file in one of the node_modules folders?


I tried to set assetBundlePatterns" to ["**/"], ["assets/"], and nothing worked.

  "bundledAssets": [


And error:
Error: is too small

Is it possible to say which assets or which dependency is causing trouble? The name here looks more like a hash

@dominikst can you try ["assets/**/*"] ?

Can you verify with expo export if file like that shows up in dist directory?


Using “assets/**/*” doesnt seem to change anything.

After the command:
expo export --public-url --dev
There are 3 files less in dist/assets than in ~/.turtle/workingdir/android/sdk36/android-shell-app/app/src/main/assets:

  • shell-app-manifest.json,

  • asset_ca1c211b75e1efc987f87cbbdef29d11.json -> copy of language file nl.json, that was removed from the project

  • 8a80554c91d9fca8acb82f023de02f11->probably some empty language json file. I had there many empty language files, all are removed, but probably cached somewhere

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.