Starting on Android emulator doesn't work, can't find emulator

Please provide the following:

  1. SDK Version:
    4.0.13 (not sure if that’s the expo cli or sdk version. I ran expo --version in my cmd window )
  2. Platforms(Android/iOS/web/all):
    Android API 22 (I also tried API 26 and API 30)
    The phones I tried in the emulator
    Nexus 4
    Pixel 4
    Pixel XL
    I use the AVD emulators from android studio (I tried Genymotion, but I was only able to start the cloud version and that didn’t help, at least Metro Bundler couldn’t find it when I clicked on “Run on Android device/emulator”) in the Expo DevTool on localhost:19002.

I was able to run my react app on my android smartphone with the expo client app, but I need to run it on the emulator, too.

I tried following:

start Android Studio -> configure -> AVD Manager -> start one of my installed emulators (e.g. Pixel XL with API 26) in the AVD -> the emulator shows up with the normal startscreen.

Then in my project: expo start -> open localhost:19002 -> Run on Android device/emulator
Error in metro:
Warning: Couldn’t adb reverse: device ‘adb’ not found
Error: Couldn’t start project on Android: Error running adb: device ‘adb’ not found

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.