Standalone build failed with EAS build but works locally: "Couldn't find Android manifest"

I work on windows and ejected the project from managed workflow. I opened the project on Android simulator with the command react-native run-android and the results were good and it worked.

I then followed the tutorial of Expo docs on EAS Build. But got the errors message: “Build failed: Couldn’t find Android manifest at /build/src/services/worker/workingdir/build/android/app/src/main/AndroidManifest.xml”

Obvisouly there is something wrong with the configuration but I can’t not see anything about this in the docs.

I built it with managed workflow with EAS build and it worked fine there.


I read the thread EAS Build Android Error spawn ./gradlew EACCES

I copied the solution git update-index --chmod=+x android/gradlew

but it seems to gave me a other error:
Fri, 08 Jan 2021 14:50:33 GMT

Starting gradle build

27Fri, 08 Jan 2021 14:50:33 GMT[stderr]

/usr/bin/env: 'sh\r': No such file or directory

28Fri, 08 Jan 2021 14:50:33 GMT

Build failed: ./gradlew exited with non-zero code: 127

I think the idea is the same that there might be some error with the line endings
I followed the Configuring Git to handle line endings - GitHub Docs but with same output error

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.