Standalone APK built with Expo SDK 47 crashes at specific device

Hello, I am getting issues when i try to use the production mode (APK) of my first expo app.

The development environment works nice with Emulator+Expo Go (Never got error logs from console)

The production build works nicely on my android emulator.
But the production build does not works on my physical device (Android 7.1.1)

Expo Go App is crashing on my physical device (Android 7.1.1)

All builds went successfully with EAS Build:

Environment:

  • Expo: SDK 47 (~47.0.3)
  • Managed workflow
  • Physical Device: Samsung Galaxy Note 8 (Android 7.1.1)

What you have tried so far:

  • Already tried npx expo start --no-dev --minify expo go, works nicely on the emulator
  • Tried to use expo go from my physical device, but it is crashing

Issued is fixed, after updating Expo to version ~47.0.5

same with me. how can ı upgrage expo to 47.0.5. ı already try expo upgrade but it waitin only integer value.

open your package.json, change the version for the expo package to ~47.0.5, then run npm install or yarn install

I did that yes. but I still had a problem getting the apk at the build stage

error

Cannot invoke method getAbsolutePath() on null object

error

com.android.builder.errors.EvalIssueException: compileSdkVersion is not specified. Please add it to build.gradle

share a link to your build page? it seems like maybe you have some library that isn’t configured properly

here

check out the expo doctor step and also, if you don’t intend for this to be a bare project, take note of the prebuild phase being skipped

I tried many things but it gives errors that I don’t understand. as you said i deleted android folder and prebuild worked. I also removed the packages found in the expo doctor (I still don’t understand why they don’t work here while they work in 44). I am still getting the same error. Why am I stuck with expo modules during the build phase? here is my build page

are you able to run your build locally successfully? Troubleshooting build errors and crashes - Expo Documentation