SQLite Error "undefined is not an object(evaluating '_expoSqlite.SQLite.openDatabase') after upgrading from SDK 34 to 35

Please provide the following:

  1. SDK Version:
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject",
    "test": "jest --watchAll"
  "jest": {
    "preset": "jest-expo"
  "dependencies": {
    "@babel/core": "^7.6.0",
    "@expo/samples": "~3.0.3",
    "@expo/vector-icons": "^10.0.0",
    "@ptomasroos/react-native-multi-slider": "^1.0.0",
    "@react-navigation/web": "^1.0.0-alpha.9",
    "expo": "^35.0.0",
    "expo-asset": "~7.0.0",
    "expo-constants": "~7.0.0",
    "expo-font": "~7.0.0",
    "expo-sqlite": "~7.0.0",
    "expo-web-browser": "~7.0.1",
    "prop-types": "^15.7.2",
    "react": "16.8.3",
    "react-dom": "16.8.3",-
    "react-native": "https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz",
    "react-native-gesture-handler": "~1.3.0",
    "react-native-maps": "~0.25.0",
    "react-native-reanimated": "~1.2.0",
    "react-native-screens": "~1.0.0-alpha.23",
    "react-native-swipe-list-view": "^2.0.1",
    "react-native-web": "^0.11.7",
    "react-navigation": "^4.0.2",
    "react-navigation-stack": "^1.5.4",
    "react-navigation-tabs": "^2.4.1"
  "devDependencies": {
    "babel-preset-expo": "^7.0.0",
    "jest-expo": "^35.0.0"
  "private": true
Expo CLI 3.9.0 enviroment info:
		OS: Windows 8.1
		Yarn: 1.19.1 - C:\Program Files (x86)\Yarn\bin\yarn.CMD
		npm: 6.9.0 - C:\Program Files\nodejs\npm.CMD
  1. Platforms(Android/iOS/web/all): IOS/Android (managed expo app)\

Followed directions for upgrade to SDK 35 from 34 for an expo managed app.

After Bundling and loading to the home screen get the error:

"undefined is not an object (evaluating '_expoSqlite.openDatabase')"

pointing to this section of code:

import { SQLite } from 'expo-sqlite';
const db = SQLite.openDatabase("db.db");

I tried to run yarn cache clean and deleted and reinstalled node modules, uninstalled expo on my device and re installed but same error.

Hey @glburgess,

Can you run expo install expo-sqlite in your project and then import it via
import * as SQLite from 'expo-sqlite' and see if that helps?


What @adamjnav said.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.