Splash screen white flash

I’m having issues with a white flash that occurs very briefly during startup when running a release build on iPhone 8. I’m using SDK 37 and expo-splash-screen 0.2.0.


I’ve read this thread [expo-splash-screen] No native splash screen registered for given view controller.Call 'SplashScreen.show' for given view controller first · Issue #7689 · expo/expo · GitHub and updated my AppDelegate.m accordingly.

I’ve also tried applying the “pro tips” at Running On Device · React Native with no luck.

This is what my App.js looks like: import React from 'react'import * as Font from 'expo-font'import { Ionicons - Pastebin.com
and this is what my AppDelegate.m currently looks like: /** * Copyright (c) Facebook, Inc. and its affiliates. * * This source cod - Pastebin.com

I’m eternally grateful for any pointers as I’ve been stuck with this for days.

1 Like

So I’ve tried basically every code snippet on the web regarding this issue probably twice by now. Those were mostly additions to AppDelegate.m (adding a loadingView, setting backgroundColor to a image etc.) Nothing solved this issue though, and I think this glitch might be occuring earlier than what those code snippets were solving?

This issue doesn’t appear if I close the app and restart it right afterwards. It’s most apparent after a fresh install, but happens every other time I start the app. I only see this in a standalone build running on a iPhone 8 through TestFlight. It appears in both release and debug mode. My friend who has a iPhone X doesn’t see this issue though.

I’ve tried using react-native-splash-screen and got it all set up with a .xib file, but still experienced this issue. I’ve also tried react-native-bootsplash but it’s generation tool says I have an invalid app.json (probably since I’m ejecting from Expo)

I’ve tried creating a new .storyboard in Xcode. Previously I used the expo-splash-screen generation tool.

I’ve tried replacing the splash screen with a smaller image (my current one is a high resolution photo, ~5mb) which made the glitch less glitch less apparent and not always occurring, but I still see the glitch almost every time I reinstall the app)

My initial hypothesis was that this somehow was related to expo-updates, as some similar issues has been reported on GitHub. I’ve tried disabling expo-updates.

My bundle size is 3,3 mb, which I also have suspected as what’s causing this flicker (I’ve tried removing the bundled assets) but I have a quite large app. Is that a too large bundle size?

This splash screen worked perfectly fine in a managed Expo app, which is released to the App store, so it must be possible to get the same experience in the bare workflow.

Is anyone else experiencing this?
What else can I try?

expo: 37.0.8
react: 16.9.0
react-native: 0.61.5
expo-updates: 0.1.0
expo-splash-screen: 0.2.0

I finally solved this by creating a new React Native project from scratch and move the code over (which was actually a lot easier than anticipated).

I have the same problem with error : “No native splash screen registered for given view controller. Call ‘SplashScreen.show’ for given view controller first.”

can you tell me how you fixed it ? what do you mean by moving thecae over ?


I meet the same issue in bare workflow in SDK 37

1 Like